BuddyPress, WordPress y bbPress

Blog

Advertencias sobre WordPress 3.0 Aún estáis a tiempo y nuevo archivo de traducción

Como algunos de vosotros sabéis, cada pocos días publico una nueva traducción actualizada de WordPress 3.0 Alpha.

Gracias a esto, es más fácil seguir los cambios que se van produciendo en el Core de WordPress.

En estas últimas actualizaciones que he realizado, han aparecido unas advertencias que me parece importante que conozcáis ahora.

A medida que surjan de nuevas, las iré publicando, así podréis estar preparados para el lanzamiento de WordPress 3.0

Primero decir que el archivo de traducción que os podéis descargar, ya traduce la totalidad de WordPress 3.0 Alpha, ya que ya han añadido las strings de traducción que faltaban. Así que los que quieran probarlo, ya lo tendrán en su totalidad traducido al español. A menos que quede algo que no haya detectado, como podrían ser mensajes de error o advertencias. Así que si lo deseáis, ya os lo podéis descargar de la sección ‘Descargas’ de esta mi web BuddyPress-es.com

Y ahora os muestro lo que he encontrado en la traducción.

He localizado y traducido los siguientes strings:

[php]%1$s está <strong>obsoleto</strong> desde la versión %2$s. Utiliza %3$s en su lugar.
%1$s está <strong>obsoleto</strong> desde la versión %2$s y no hay alternativas disponibles.
%1$s fue llamado con un argumento que está <strong>obsoleto</strong> desde la versión %2$s! %3$s
%1$s fue llamado con un argumento que está <strong>obsoleto</strong> desde la versión %2$s y no hay alternativas disponibles. [/php]

De momento, los argumentos que están obsoletos no los conozco, pero aquí tenéis los que proponen para su sustitución:

[php]get_the_author()
get_trackback_url()[/php]

Si tenéis argumentos que tienen la misma función que los anteriores, sustituirlos por estos, ya que es muy posible que, si no lo hacéis, os lance la advertencia que os he mostrado anteriormente.

Como comento, a medida que vayan saliendo nuevos strings de este tipo, los iré publicando, ya que si no, en el momento que actualicéis a WordPress 3.0, os podéis encontrar en que hay partes de vuestro sitio que no funcionen.

Otro que he encontrado es este:

[php]La opción ‘%1$s’ ya no se usa para la familia de funciones bloginfo(). Usa la opción ‘%2$s’.[/php]

Así que hay argumentos de la familia bloginfo() que desaparecen.

En la WordCamp Spain del 2009, RaveN (que participa en el core de wordpress) de la empresa Mecus, ya nos advirtió que se iba a depurar el core de WordPress, ya que no tenía sentido que WordPress fuera compatible con funciones de las primeras versiones. La intención de esta limpieza es dejar funciones nuevas, que mejoran y son más flexibles que las antiguas y conseguir un WordPress menos pesado y más rápido.

Así que parece que ya han comenzado con la limpieza.

Si usáis Temas antiguos, estar bien atentos, ya que es muy posible que bajo WordPress 3.0 no os funcionen.

Ahora estáis a tiempo de entrar de lleno en WordPress 3.0 el mismo día que se libere. Pero vosotros elegís, entráis sin problemas con vuestro tema, actualizando las funciones o cambiáis de tema el día que actualicéis, ya que no os funcionará.

1 Comentario

Comentarios

01
Bitacoras.com
28 enero, 2010

Información Bitacoras.com…

Valora en Bitacoras.com: Como algunos de vosotros sabéis, cada pocos días publico una nueva traducción actualizada de WordPress 3.0 Alpha. Gracias a esto, es más fácil seguir los cambios que se van produciendo en el Core de WordPress. En estas última…..

 

Dejar un comentario